
Microangelo Studio Colors

To choose a color, position the cursor over any color well in the color box, then click the left mouse 
button to set Color   ‘  A  ’  , or click the right mouse button to set Color   ‘  B  ’  .    The color box is a free 
floating pop up window.    It can be turned on or off from the View menu.
The tools in the Microangelo Studio tool box use the ‘A’ and ‘B’ colors for all drawing operations.    
The currently selected ‘A’ and ‘B’ colors are displayed in the status panel to the left of the grid area

Color Box
Microangelo Studio initializes the color box with the complete range of colors used by the current 
image being edited.    In addition to providing monochrome, 16, and 256 regular painting colors, the
color box also includes color wells that contain transparent and inverse screen ink.    To create or 
edit icon images in different color formats, select an existing image format from the Image Format 
combo box on the tool bar, or add a new image by clicking the New Image Format button on the far 
right of the tool bar.
Palette Files
The Studio initializes the color box for a new 256 color image using a default palette file included 
with Microangelo (default.pal).    You can save different palette files on your system by opening the 
Edit menu and clicking Save Palette, and use them again later by clicking the Open Palette option.    
The palette files used by Studio are not binary PAL files used by some Windows applications.    They 
are ASCII text files in a format used by Paint Shop Pro from JASC, Inc.    So in addition to being able 
to edit colors graphically in the Studio, you can also edit your palette files in a plain text editor such
as Notepad.    (Do not attempt to edit a palette file using Wordpad or any other word processing 
application).    The header records are followed by color definitions, one color per record.    Colors 
are defined by their relative red, green, and blue components in intensities from 0 to 255.
Creating Custom Colors
When editing an image containing 256 colors, you can edit any color in the color box by double 
clicking directly on its color well.    If you create a 256 color icon and customize colors in the color 
box, you can save the color palette by clicking Save Palette on the Edit menu.
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How Colors are Used by the Drawing Tools
Drawing

The left mouse button is used with most of the drawing tools to paint using the primary 'A' color, 
and the right mouse button is used to paint using the secondary 'B' color.    The Pencil, Line, Brush, 
Flood, Rectangle, and Ellipse functions operate in this manner.

Color Eraser
The 'A' and 'B' colors are used to specify the foreground and background colors for the color eraser. 
The tool will change the 'A' (foreground) color to the 'B' (background) color.    Using the right mouse 
button instead of the left will reverse this operation, changing any 'B' color under the Eraser to the 
'A' color.

Selection frame
The 'B' (background) color is also used when the selection frame is used to cut or drag a selection 
to a new location.    The desired 'B' color must be chosen before making the selection.
When a cut operation is performed, or the selection is dragged to a new location, the area the 
image previously occupied is filled with the 'B' color.
You can also use the Tools menu and click Paste and Drag to select either the Transparent or 
Opaque color ‘B’ option.    When a selection is dragged and the Transparent Color B option is in 
effect, any area in the selection that matches the 'B' color will be treated as a transparent area 
during the drag.
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Pencil tool
1    Click the Pencil tool button in the tool box; or on the Tools menu, click Choose Tool.Pencil.
2    Move the Pencil to the place on the icon where you want to start drawing.
3    Click the left mouse button (for Color ‘A’) or the right button (for Color ‘B), and hold it down as 

you draw.
4    Release the mouse button.
Tip
· Pressing either SHIFT key will restrict the Pencil tool to the current row or column.    You can press 

and release the SHIFT key more than once during a single draw to restrict and free the drawing 
motion.



Brush tool
1    Click the Brush tool in the tool box; or on the Tools menu, click Choose Tool.Brush.
2    Select a shape representing the brush you want to draw with from the tool pan directly below the

toolbox.    A highlight appears around the shape you have selected.
3    Move the cursor to the place on the icon where you want to start drawing.
4    Click the left mouse button (for Color ‘A’) or the right button (for Color ‘B’), and hold it down as 

you draw.
5    Release the mouse button.



Flood tool
1    Click the Flood tool in the tool box; or on the Tools menu, click Choose Tool.Flood.
2    Move the cursor to the area you want to fill.
3    Click the left or right mouse button to flood with Color ‘A’ or Color ‘B’, respectively.



Color eraser
1    Click the Color eraser in the tool box; or on the Tools menu, click Choose Tool.Color Eraser.
2    Select a shape representing the Eraser you want to use, from the area below the toolbox.    A 

rectangle appears around the option you have selected.
3    Move the Eraser to the place on the icon where you want to start editing.
4    Click the left mouse button to replace Color ‘A’ with Color ‘B’.    Click the right mouse button to 

replace Color B with Color A.



Straight line tool
1    Click the Straight line tool in the tool box; or on the Tools menu, click Choose Tool.Straight Line.
2    Place the cursor at the starting point for the line.
3    Drag the cursor to where the line will end.    The origin and the X and Y components of the line 

will be displayed in the status bar.
4    Release the mouse button to complete the drawing operation. 
Tip
· Press either SHIFT keys to restrict the line to increments of 45 degrees.



Rectangle tool
1    Click the Rectangle tool in the tool box; or on the Tools menu, click Choose Tool.Rectangle.
2    Move the cursor to one corner of the of the rectangle.
3    Drag diagonally to the opposite corner.    The origin and size of the rectangle will be displayed at 

the far right of the status bar.
4    Release the mouse button to complete the drawing operation.
Tip
· Press either SHIFT keys to restrict the drawing to perfect squares.



Rectangle tool (filled)
1    Click the Rectangle tool (filled) in the tool box; or on the Tools menu, click Choose 

Tool.Rectangle (Filled).
2    Move the cursor to one corner of the rectangle.
3    Drag the cursor diagonally to the opposite corner.    The size of the rectangle will be displayed at 

the far right of the status bar.    (When the left mouse button is used to drag, the rectangle will be 
framed with Color A and filled with Color B.    Using the right mouse button reverses this operation 
- the rectangle will be framed with Color B and filled with Color A).

4    Release the mouse button to complete the drawing operation.
Tip
· Press either SHIFT keys to restrict the drawing to perfect squares.



Rectangle tool (solid)
1    Click the Rectangle tool (solid) in the tool box; or on the Tools menu, click Choose 

Tool.Rectangle (Solid).
2    Move the cursor to one corner of the rectangle.
3    Drag the cursor diagonally to the opposite corner. corner.    The size of the rectangle will be 

displayed at the far right of the status bar.    (When the left mouse button is used to drag, the 
rectangle will be drawn with Color A.    Using the right mouse button draws the rectangle using 
Color B).

4    Release the mouse button.
Tip
· Press either SHIFT keys to restrict the drawing to perfect squares.



Color pipette
1    Click the Color pipette tool in the tool box; or on the Tools menu, click Choose Tool.Color Pipette
2    Move the cursor over the pixel which contains the desired Color ‘A’ or Color ‘B’.
3    Click the left mouse button to replace color ‘A’ or the right mouse button to replace color ‘B’.    

The color is updated and the cursor returns to the prior drawing tool.
Note:
· The Color pipette can only be accessed from the toolbox or Tools menu when you are working with

a 256 color image.



Color locator
1    Click the Color locator tool in the tool box; or on the Tools menu, click Choose Tool.Color 

Locator.
2    Click a cell in the grid area or the color well in the color box that contains the color to be located. 

The color well will blink in the color box and in all cells in the grid area that contain the color.
Note:
· The Color locator can only be accessed from the toolbox or Tools menu when you are working with

a 256 color image.



Selection frame
1    Click the Selection tool in the tool box; or on the Tools menu, click Choose Tool.Selection 

Frame.
2    Move the cursor to one corner of the area that you want to select.
3    Drag the cursor to the opposite corner of the area you want to select. A rectangle shows which 

pixels will be selected. All pixels within the rectangle, including those "under the rectangle," are 
included in the selection.    The size of the area selected will be displayed at the far right of the 
status bar.

4    Release the mouse button to complete the select operation. A highlighted border will enclose the
selected area. The area may now be dragged to any other location in the work area, or operated 
on using the Cut or Copy editing commands.



Ellipse tool
1    Click the Ellipse tool in the tool box; or on the Tools menu, click Choose Tool.Ellipse.
2    Move the cursor to one corner of the of the bounding rectangular area that will contain the 

ellipse.
3    Drag diagonally to the opposite corner.
4    Release the mouse button to complete the drawing operation.
Tip:    
· Press either SHIFT keys to restrict the drawing to perfect circles.



Ellipse tool (filled)
1    Click the Ellipse tool (filled) in the tool box; or on the Tools menu, click Choose Tool.Ellipse 

(Filled).
2    Move the cursor to one corner of the of the bounding rectangular area that will contain the 

ellipse.
3    Drag diagonally to the opposite corner.    (When the left mouse button is used to drag, the ellipse 

will be framed with Color A and filled with Color B.    When the right mouse button is used this 
operation is reversed - the ellipse will be framed with Color B, and filled with Color A).

4    Release the mouse button to complete the drawing operation.
Tip:    
· Press either SHIFT keys to restrict the drawing to perfect circles.



Ellipse tool (solid)
1    Click the Ellipse tool (solid) in the tool box; or on the Tools menu, click Choose Tool.Ellipse 

(Solid).
2    Move the cursor to one corner of the of the bounding rectangular area that will contain the 

ellipse.
3    Drag the cursor diagonally to the opposite corner.    (When the left mouse button is used to drag, 

the ellipse will be drawn using Color A.    When the right mouse button is used, it will be drawn 
with Color B).

4    Release the mouse button to complete the drawing operation.
Tip:    
· Press either SHIFT keys to restrict the drawing to perfect circles.



The view menu contains options that determine what features are displayed in Microangelo Studio.  
You can toggle the display of the tool bar, the status bar, the color box, the tool box, and the editing
grid.



The status panel is located to the left of the grid area.    It displays an actual size view of the image 
being edited and the current ‘A’ and ‘B’ drawing colors.



The color box is used to select drawing colors when creating or editing an icon image. The color box
is a pop up window that can be moved anywhere on your desktop.    The color box offers a full range
of colors for the image being edited, as well as transparent and inverse screen selections.



The tool box provides access to the tools used to edit an icon image. The tool box is a pop up 
window that can be moved anywhere on your desktop.



Color A is assigned to your left mouse button.    Choose a new Color ‘A’ by positioning the cursor 
over a color well in the color box and clicking the left mouse button.



Color B is assigned to your right mouse button.    Choose a new Color ‘B’ by positioning the cursor 
over a color well in the color box and clicking the right mouse button.



The status bar at the bottom of the program window displays information and messages that 
provide feedback as you work.    It displays information about tool buttons and menu selections, and
also provides information on the cursor location and movement during drawing operations.



The Browser can be opened from the Librarian by clicking Browser on the File menu.    This is the 
best way to access to all files containing libraries when you are opening a file in a new Librarian 
window. 



The transparent ink well is available on all palettes.    It is the well that has a computer screen filled 
with a dark blue color.



The inverse screen ink well is available on all palettes.    It is the well that has a computer screen 
filled with a pink color.



Introduction to Microangelo Studio

Microangelo Studio can create, open, and save Icon Resource files.    The Studio will create or edit 
any size image from 8x8 to 64x64 pixels in monochrome, 16, or 256 color formats.

Workspace
At the center of the main window is the    grid area.    It displays the zoomed view of the icon image 
and is where all drawing actions take place.    Above the grid area is where the most commonly 
used menu commands can be accessed from the Studio tool bar.

To the left of the grid area, is the status panel that displays, from top to bottom, an actual size 
image of the icon being edited, and the current Color ‘A’ and Color ‘B’ settings.

The color box and the tool box are separate pop up windows.    Click the left or right mouse button 
over the desired color well in the color box to select a new ‘A’ or ‘B’ color.    Microangelo Studio 
initializes the new image size and color format to 32 x 32 pixels and 16 colors.    You can select the 
size and color format of a new image in an icon by clicking on the New Image Format button on the 
tool bar.
At the bottom of the program window is the status bar.    When a tool tip is activated or when one of
the tool’s from the tool box is selected, a short description of the action or tool will be displayed on 
the left side of the bar.    The current X and Y coordinates of the cursor are displayed to the right 
when it is moved over the grid area.
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General Rules for Operating the Tools

Microangelo Studio will initialize to a minimum window size.    The main window size may be 
increased, but it cannot be reduced below the minimum size.    The color box and tool box are 
separate pop up windows that can be moved anywhere on your screen.    Click the View menu to 
control the display of features in Microangelo Studio including the tool and status bars and the color
box and tool box.

Freehand tools
Drawing with freehand tools (Pencil, Brush, and Color Eraser) is performed by pressing the left or 
right button in the edit area.    Drawing continues as the mouse is moved until the mouse button is 
released.

Precision tools
Drawing with precision tools (Line, Rectangle, and Ellipse tools) is performed by pressing the left or 
right mouse button and dragging the mouse with the button depressed.    A line image of the 
potential figure is displayed in the grid area and in the actual size image in the status panel as the 
drawing action is performed.    Releasing the mouse button completes the paint operation and 
updates the icon image.

Flood tool
To paint using the flood tool, press the left or right mouse button over a color cell in the grid area.    
The pixels, and all adjacent pixels of the same color will be filled.    The operation continues until the
flood is completely bounded by different color pixels.

Selection frame
The selection frame works very much like the rectangle tool.    Press the left mouse button and drag 
to select areas of the edit image.    A selected area can be cut, copied or moved to a different 
location.    You can also    paste into the selected area using the Paste Special selection on the Edit 
menu.
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Edit menu

Undo
Reverses changes you make on an icon, such as colors, or shapes. The Undo command changes to 
Can't Undo when there are no more commands to be undone.    This will undo previous drawing 
action performed on the icon image.    The specific Undo action displayed (for example, Undo 
rectangle or Undo Flood) identifies the command that is available to be undone if you cannot 
reverse the action.

Redo
Restores drawing actions that were undone using the Undo command.    The Redo command is only 
available after using Undo and before continuing with any new drawing actions.    The specific Redo 
action displayed (for example, Redo Ellipse or Redo Flood) identifies the command that is available 
to be redone.

Cut
Removes selected graphics and puts it on the Clipboard. This command is available only when you 
select graphics.    Graphics that you place on the Clipboard remains there until you replace it with a 
new item.    

Copy
Copies selected graphics to the Clipboard.    Graphics that you copy to the Clipboard, replaces the 
previous contents.    

Paste
Inserts a copy of the Clipboard contents into the work area, replacing the selection (if any) with the 
graphics on the Clipboard. The graphics are pasted into a selection frame, where they can be 
dragged to the desired location.    Once pasted into the selection frame, dragging the image will 
insert Color ‘B’ as the background color.    This command is not available if the Clipboard is empty or
if the selected graphics cannot be replaced.    

Paste Special
This will scale a bitmap image either from the Clipboard (if an image is present), or directly from a 
bitmap file.    You will also have the option of pasting into the Studio as a New Selection, or paste 
into Studio in the current selection.    

Tip:
· You may convert a BMP file into an icon, by pasting it to the Clipboard, and using the Paste Special

option on the Edit menu.    However, if your bitmap uses colors that are not available in the 
currently active palette, the Studio will substitute the closest color available from the currently 
active palette.    To ensure color integrity, use the Open Bitmap As Image, found on the Edit menu.



The New Selection will paste the bitmap image into the grid area, without altering the size of the 
bitmap image.



The current selection is only available, if pixels has been defined in the grid area, by the selection 
frame tool.    The Studio will scale the size of the current image, into the area defined by the 
selection frame.



The Open Bitmap As Image, found on the Edit menu, is the most efficient way to convert a bitmap 
image into an icon.    With this selection, color integrity of the bitmap is preserved.    Studio will alter
the color box, to accommodate any colors that are not found in the palette, but used in the image.   
If the Paste Special selection is used, color integrity is NOT preserved.    The Studio will use a color 
close to the one used in the original bitmap image.



The selection frame defines an area of the bitmap that you can cut, copy, clear, or move.



File Menu

New
Prepares the work area to begin editing a new icon.    The new icon is initialized to the screen color.   
If you are currently working on an icon file, Microangelo Studio will prompt you to Save the icon file.

Open    (Ctrl+O)
Opens an existing icon resource file, (*.ICO) file.

Save    (Ctrl+S)
Saves the work area to the current icon resource file (*.ICO) on disk. When you save an icon for the 
first time, Microangelo Studio displays the Save As dialog box.

Update/Update and Exit
If operating the Studio through a Server mode from the Librarian, the Save function will display as 
Update.    The image will be pasted in the current window.    When edititng an exisiting icon, the 
image will be updated automatically from the file from which it was opened.    
The Update and Exit will perform the same as Update, except that the Server mode of the Studio
will close.

Save As    
Displays the Save As dialog box, where you specify the location of the icon resource file (*.ICO) on 
disk.    

Exit    (Alt+F4)
Closes the Microangelo Studio program.



Tools menu

Selection frame
The selection frame defines an area of the bitmap that you can cut, copy, clear, or move.

Pencil
Draws in a constant width of one pixel. Drawing continues as the mouse is moved until the mouse 
button is released.

Straight line
Draws a line, filled with Color ‘A’ or Color ‘B’. A line image of the potential figure is displayed for 
your inspection as the cursor is dragged.    Releasing the mouse button completes the paint 
operation and updates the icon image.

Brush
Colors multiple pixels using the current brush size and shape. Drawing continues as the mouse is 
moved until the mouse button is released.

Flood
Replaces an area of one color with another color. The pixels, and all adjacent pixels of the same 
color will be filled.    The operation continues until the flood is completely bounded by different color
pixels.

Color eraser
Used to selectively replace one color with another color. Editing continues as the mouse is moved 
until the mouse button is released.

Rectangle
Draws a rectangle framed with Color ‘A’ or Color ‘B’. A line image of the potential figure is displayed
for your inspection as the cursor is dragged.    Releasing the mouse button completes the paint 
operation and updates the icon image.

Rectangle (filled)
Draws a rectangle filled with Color ‘A’ or Color ‘B’.

Rectangle (solid)
Draws a rectangle framed with Color ‘A’ and is filled with Color ‘B’.

Ellipse
Draws an ellipse framed with Color ‘A’ or Color ‘B’. A line image of the potential figure is displayed 
for your inspection as the cursor is dragged.    Releasing the mouse button completes the paint 
operation and updates the icon image.

Ellipse (filled)
Draws an ellipse filled with Color ‘A’ or Color ‘B’.

Ellipse (solid)
Draws an ellipse framed with Color ‘A’ and is filled with Color ‘B’.

Color pipette 
Picks up Color ‘A’ or Color ‘B’ from the editing area. This option will become available in the Tools 
menu, and the tool box, when creating or editing an image with more than 16 colors.

Color locator
Locates the color in the grid area, and the color box.    All instances where the color was located in 
the grid area, will blink. This option will become available in the Tools menu, and the tool box, when 
creating or editing an image with more than 16 colors.



View menu

Toolbar
This option shows or hides the tool bar from the Studio’s display.    The tool bar provides quick and 
easy selection of commonly used options.

Status bar
This option shows or hides the status bar from the Studio’s display.    The status bar is located at the
bottom of the program window.    It displays descriptive information when a menu item is 
highlighted, or one of the tool tips is activated.

Color box
This option shows or hides the color box from the Studio’s display.    The color box is an independent
window, and can be moved anywhere on your desktop.    The palette will offer more colors when the
image format is changed (depends on the capability of your individual system).

Tool box
This option shows or hides the tool box from the Studio’s display.    The tool box is an independent 
window, and can be moved anywhere on your desktop.    It contains all tools available to create or 
edit icon images.

Grid
This option shows or hides the grid from the Studio’s display.



Open a Color Palette

1    Set the image format to 256 colors, (you may select any size).
2    Click Open Palette from the Edit menu.
3    Browse to the folder where the palette is stored.
4    Select the palette, and click Open.

Note:
· You are only able to open a 256 color palette.    The 16 primary colors are established, and are 

unable to be edited.



Save a Color Palette

1    Set the image format to 256 colors, (you may select any size).
2    Click Save Palette from the Edit menu.
3    Name the palette, and choose the folder in which it is to be saved.

Note:
· You are only able to save a 256 color palette.    The 16 primary colors are established, and are 

unable to be edited.



Edit a Color

1    With the 256 color box active, double click on the color to be edited.
2    From the Blend Color    dialog, make changes to the color.
3    Click OK to return to editing the icon image.

Note:
· You are only able to edit a color in a 256 color box.    The 16 primary colors are established, and 

are unable to be edited.



Create Icon Resource

1    Click New from the File menu.
2    If you are currently working in an edit session of another image, you will be prompted to save 

current file, before opening a new file.
3    Microangelo Studio will open with a blank grid area to start creating a new icon.
4    Once drawing has been completed, click Save As from the File menu.
Tip:
· If you would like to experiment with the editing of an image, click Update from the File menu.    

This will update the image in the file, but leave the Studio open, so that you may edit the image 
with different color schemes, or shapes, etc.



Create ‘Custom’ Size Image for Icon Resource

1    Click New from the File menu.
2    Microangelo Studio will open with a blank grid area to start creating a new icon.
3    Click the New Image Format button (far right of tool bar), and choose the size, and number of 

colors from the different options; or scroll to the Custom... selection and define your own.
4    Once editing has been completed, click Save As from the File menu.
Tip:
· Once you have created several different formats, for a particular image, you will be able to edit 

the different formats, by quickly referencing them from the Image Format combo box.



Edit Icon Resource

1    Click Browser from the File menu.
2    Click the Icons Tab.
3    Browse to the folder that contains icon.
4    Double-click on the icon image that you would like to edit.
5    Make any desired changes to the image.
6    Click Save from the File menu.



Creating an Icon Resource From a Bitmap

1    Click New from the File menu.
2    Click the New Image Format button (far right of tool bar), and choose the size, and number of 

colors from the different options; or scroll to the Custom... selection and define your own.
3    Click Open Bitmap File from the Edit menu.
4    Browse to the folder which contains the bitmap file.
5    Select the file, and click Open.
6    Click Save As from the File menu to save image as an icon.
Tip:
· You may also convert a BMP file into an icon, by pasting it to the Clipboard, and using the Paste 

Special option on the Edit menu.    However, if your bitmap uses colors that are not available in the
currently active palette, the Studio will substitute the closest color available from the currently 
active palette.    To ensure color integrity, use the Open Bitmap As Image, found on the Edit menu.



Open Icon Resource

1    Click Browser from the File menu.
2    Click Icons Tab.
3    Browse to the folder that contains the icon.
4    Double click on icon.
5    Studio will open the image, and place it in the grid area, ready to be edited.



Edit Icon Image in a Library

1    Click Browser from the File menu.
2    Click Libraries Tab.
3    Browse to the folder which contains the file.
4    Double click on file to open.
5    Double click on icon to be edited.
6    Librarian will initialize in Server mode with the Studio component.




